Jul
15

We are renewing the SSL/TLS certificates on our API endpoint. 

Sandbox (https://api-cert.payeezy.com) - 15 July 2016
Live - (https://api.payeezy.com) - 26 July 2016 at 2:00 AM EST

Who is impacted
This upgrade only impacts merchants who use the Payeezy API integration methods and store the Payeezy API certificate in their certificate store.  The Payeezy API integration methods include Direct API, Payeezy.JS, Android Pay and Apple Pay. 

There is no impact to merchants using Web Service API, Hosted Checkout or Real Time Payment Manager.

Impact and Action Required
Merchants using the Payeezy API integrations need to verify if they currently store a copy of the Payeezy SSL/TLS certificate in their certificate store. If they do, they need to update the Payeezy API SSL/TLS certificate in their certificate store. Failure to do so may result in issues connecting to Payeezy API.  Merchants can go to https://developer.payeezy.com/files/apipayeezycom-pubkey-cb2ecerpem and download the new SSL/TLS certificate.

If you have questions or concerns about this communication, leave a comment below or contact the Payeezy Gateway Technical Support Team at 1-855-448-3493.


Comments


Hi Team,

Can i get the updated SSL/TLS certificates for the sandbox API endpoint.

Merchants can go to https://developer.payeezy.com/files/apipayeezycom-pubkey-cb2ecerpem and download the new SSL/TLS certificate.

In FirstData module folder have this file firstdata-cert.pem and i try to replace content of file with https://developer.payeezy.com/files/apipayeezycom-pubkey-cb2ecerpem and from this also https://support.payeezy.com/hc/en-us/articles/223607367-Payeezy-Gateway-SSL-Certificate-Update-Details

But it is given same Error "First Data Gateway Connection error: Unable to read response, or response is empty. SSL certificate problem: certificate has expired (60)"

Using Sandbox

I'm getting this error when trying to use the sandbox url: "https://api-cert.payeezy.com/v1/transactions":
"SSL certificate problem: certificate has expired"

The cert linked here is for the domain api.payeezy.com, which one do I have to install?